Brave on ElementaryOS

I wanted to install Brave on a test ElementaryOS install and I’d rather use apt instead of the .deb file that’s on Brave’s main site. Brave does have a repo available but it won’t work with ElementaryOS out of the box. Here are the instructions.

The trick is here: “You will want to make sure the bottom line of /etc/apt/sources.list lists a new repository and doesn not contain the word lsb_release.”

When you run the two provided commands:

curl https://s3-us-west-2.amazonaws.com/brave-apt/keys.asc | sudo apt-key add -
echo "deb [arch=amd64] https://s3-us-west-2.amazonaws.com/brave-apt `lsb_release -sc` main" | sudo tee -a /etc/apt/sources.list

…’loki’ is inserted into the new source in /etc/apt/sources.list. Replace it with ‘xenial’.

Brave installed just fine with apt after that.

Advertisements